【通达信】黑马一二三指标公式-2010典藏版

2010-03-09 14:36:32来源:未知作者:wenshu

 

VAR6:=((((2 * CLOSE) + HIGH) + LOW) / 4);
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((((VAR6 - VAR7) / (VAR8 - VAR7)) * 100),13);
VARA:=EMA(((0.667 * REF(VAR9,1)) + (0.333 * VAR9)),2);
多:VAR9,POINTDOT,COLORFF00FF;
空:EMA(((0.382 * REF(VAR9,2)) + (0.618 * VAR9)),12),COLORFFCC66;
STICKLINE((VAR9 > VARA),VAR9,VARA,4,0);
STICKLINE((VAR9 <= VARA),VAR9,VARA,4,0);
黑马一:IF(((((VOL / 120) > (MA(VOL,5) / 120)) AND (CLOSE > (OPEN * (1 + (4.8 / 100))))) AND (CLOSE < (MA(CLOSE,30) * 1.6))),40,0),COLORWHITE,POINTDOT;
STICKLINE( 黑马一,40,0 ,1,1 ),COLORWHITE;
VAR1:=IF(((MA(VOL,5) / 120) AND (CLOSE > (REF(CLOSE,1) * 1))),8,0);
VAR2:=IF(((((((CLOSE / REF(CLOSE,1)) >= 1.05) AND (((VOL / CAPITAL) * 100) < 10)) AND (CLOSE < 18)) AND ((HIGH / CLOSE) < 1.01)) AND (VAR1 > 0)),10,0);
VAR3:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR4:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);
FNZH:=((VAR4 < (0 - 50)) AND (VAR3 > 7));
黑马二:IF(((VAR2 > 9) OR FNZH),35,0),COLORFF00FF,POINTDOT;
STICKLINE(黑马二 ,35 ,0 ,1, 1),COLORFF00FF;
AR1:=IF((((CLOSE AND (MA(VOL,5) / 120)) AND (CLOSE > (REF(CLOSE,1) * 1))) AND CLOSE),88,0);
VARR:=IF(((((((CLOSE / REF(CLOSE,1)) > 1.05) AND (((VOL / CAPITAL) * 100) < 10)) AND (CLOSE < 17)) AND ((HIGH / CLOSE) < 1.01)) AND (VAR1 > 0)),91,0);
黑马三:IF((VARR > 90),30,0),COLORFFCC66,POINTDOT;
STICKLINE(黑马三 ,30, 0,1,1 ),COLORFFCC66;

快速索引: